My Oracle Support Banner

G-Invoicing Seller Side OKE_FUNDING_PUB.CREATE_FUNDING Error: "You cannot allocate funding for agreements that have Advance Required option enabled." (Doc ID 2885464.1)

Last updated on JULY 26, 2022

Applies to:

Oracle Project Billing - Version 12.2.11 and later
Information in this document applies to any platform.

Symptoms

Users are trying to use Project Contracts to create an agreement with the "Advance Required" flag set to 'Yes'.
When calling the OKE_FUNDING_PUB.CREATE_FUNDING API the following error is encountered:

"You cannot allocate funding for agreements that have Advance Required option enabled."

Steps to reproduce:

1.  Created a project and project contract agreement using an internal custom process.
2 . Initiated the Project Contract Approval Workflow to accept the order and called OKE_FUNDING_PUB.CREATE_FUNDING API

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.