Oracle Transportation Management - Errors Running dbpatch_55.sql On A new v5.5 Instance (Doc ID 435672.1)

Last updated on JULY 09, 2014

Applies to:

Oracle Transportation Management - Version: 5.5 to 5.5 - Release: 5.5 to 5.5
Linux x86-64
Checked for relevance on 15-Jan-2010

Symptoms

-- Problem Statement:

Client is running dbpatch_55.sql on a newly installed system and the following error is being
generated during the process.

Error while connecting with oci8 driver to OTMSTG:
oracle.aurora.server.tools.loadjava.ToolsException: The JDBC OCI8 Driver is not installed
properly, use -thin to try the JDBC Thin driver:
/oracle/ent10g/client/product/home/lib32/libocijdbc10.so: libclntsh.so.10.1: cannot open shared
object file: No such file or directory
exiting : could not open connection

-- Steps To Reproduce:
Create a new OTM instance with RH 4.0 64 bit OS with the 64 bit Oracle client
Go to the < otm home >/glog/oracle/script8 directory
Log into the database as glogowner using sqlplus and run dbpatch_55.sql
Errors will be generated on the screen and should be listed in the dbpatch_55 logs as well.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms