BPEL to OTM Integration is Not Working and the Error "The browser is sending an invalid" is Displayed. (Doc ID 761741.1)

Last updated on SEPTEMBER 08, 2016

Applies to:

Oracle Transportation Management - Version: 5.5.01
This problem can occur on any platform.

Symptoms

-- Problem Statement:


When integration is initiated on EBS by running the concurrent program "Shipping-Transportation Carriers Synchronization", it kicks of a parent process on BPEL which is called "WshSendLocRefDataToOtm".

This "WshSendLocRefDataToOtm" process in turn invokes "WshSendRefDataStlToOtm".

The parent process "WshSendLocRefDataToOtm" completes however the child process "WshSendRefDataStlToOtm" fails with the following error:

Error
=====

<TransmissionAck><HTML> <HEAD><TITLE>500 Server
Error</TITLE></HEAD> <BODY> <H1>Server Error</H1> <H4> The
following error occurred:<P> [code=UNRECOGNIZED_REQUEST] The browser is sending an invalid
request. Contact your system administrator. </H4> <HR> Please contact the
administrator. </BODY> </HTML> </TransmissionAck>
<selectionFailure>
<part name="summary" >
<summary>empty variable/expression result. xpath variable/expression expression
"/ns2:TransmissionAck/ns2:EchoedTransmissionHeader/ns2:TransmissionHeader/ns2:ReferenceTransmissionN
o" is empty at line 77, when attempting reading/copying it. Please make sure the
variable/expression result
"/ns2:TransmissionAck/ns2:EchoedTransmissionHeader/ns2:TransmissionHeader/ns2:ReferenceTransmissionN
o" is not empty. </summary>
</part>
</selectionFailure>

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms