RapidClone fails on Applications Tier using JRE 1.1.8: "Could Not Open Java.Lang.Noclassdeffounderror: Oracle/Jdbc/OracleDriver" (Doc ID 789942.1)

Last updated on OCTOBER 24, 2016

Applies to:

Oracle Applications Manager - Version 11.5.10.2 to 11.5.10.2 [Release 11.5.10]
Oracle Applications DBA - Version 11.5.10.2 to 11.5.10.2 [Release 11.5.10]
Information in this document applies to any platform.
<>11i RAPIDCLONE CONSOLIDATED FIXES JUL/2008
The specific issues in this document refer to Applications Tiers that are still using JRE 1.1.8.

***Checked for relevance on 21-Dec-2012***


Symptoms

RapidClone fails with error during Context file creation after entering port pool:

Checking the port pool xx
done: Port Pool xx is free

Complete port information available at
<APPL_TOP>/admin/out/<CONTEXT_NAME>/portpool.lst

Verifying Database Connection...
Exception in thread "main" ERROR: Could not open java.lang.NoClassDefFoundError:
oracle/jdbc/OracleDriver

Another symptom of this issue can occur if the context file is already created, where the RapidClone command contains an error:

ERROR : Unable to set CLASSPATH
<COMMON_TOP>/clone/bin/../jlib/classes111.zip: is missing
Beginning application tier Apply - Tue Jul 31 13:29:38 2007
Log file located at
<APPL_TOP>/admin/<CONTEXT_NAME>/log/ApplyAppsTier_xxxxxx.log
- 39% completed

RapidClone also fails at 39% with error:

RC-50004: Fatal: Error occurred in ApplyAppsTier:

StackTrace -
java.lang.reflect.InvocationTargetException
at oracle.apps.ad.clone.util.CloneProcessor.run(Compiled Code)
at java.lang.Thread.run(Compiled Code)

ERROR while running Apply...

ERROR: Failed to execute <COMMON_TOP>/clone/bin/adclone.pl

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms