How To Upgrade To Paypal Version 4.x SDK (Doc ID 804338.1)

Last updated on MAY 16, 2017

Applies to:

Oracle Payments - Version 11.5.10.0 to 11.5.10.2 [Release 11.5]
Information in this document applies to any platform.
Oracle iPayment - Version: 11.5.9 to 11.5.10.2
Paypal SDK V4


Goal

Integration of Paypal Payflow 3.x with Oracle iPayment will be reaching EOL on September 1st, 2009. PayPal will be upgrading its Payflow gateway service to a new, more secure SSL server certificate hierarchy in September 2009. To continue processing transactions after this date, you are required to upgrade your current Paypal integration to the latest Software Development Kit (SDK version 4.3+). After September 1st, 2009, you can no longer use Payflow version 3.x.

In general, upgrade of Paypal Payflow does not require any setup changes in iPayment. Only changes required are related Paypal Jar files and update to apache configuration. This note provide some useful information for customer's planning to upgrade to Paypal SDK V4.3.

Note: All of the information covered here pertains to Paypal software upgrade. Since Paypal is a third party software vendor, Oracle has no control over potential changes to this information. For any issue, please contact Paypal Support using the link provided below.

 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms