Implementing Configurator return servlet with JSP tag library (Doc ID 944949.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Configurator Developer - Version: 12.1.1 and later   [Release: 12.0 and later ]
Information in this document applies to any platform.

Goal

How does one ensure that a return servlet functions correctly when attempting to use jsp tag library in Configurator Release 12.1.1?

Following is the initial setup:

A) Included the return_url in the initialize message:
(<paramname=return_url>http://ebapp.com:8001/OA_HTML/xxmsc/CZTerminationServlet</param>)

B) Updated the
$ORA_CONFIG_HOME/10.1.3/j2ee/oacore/application-deployments/oacore/html/orion-web.xml file with the below snippet. The snippet has to be inserted before </web-app> :

<!-- CZ servlets -->
<servlet>
<servlet-name>CZTerminationServlet</servlet-name>


<servlet-class>us.servicecenters.cz.CZTerminationServlet</servlet-class>
</servlet>
<!-- CZ alias -->
<servlet-mapping>
<servlet-name>CZTerminationServlet</servlet-name>
<url-pattern>/xxmsc/CZTerminationServlet</url-pattern>
</servlet-mapping>

C) Uploaded the jar file which contains the CZTerminationServlet to
/oracle/ebs12/us/ebsustst/apps/tech_st/10.1.3/j2ee/oacore/applications/oacore/html/WEB-INF/lib

D) Added the jar file to:
/oracle/ebs12/us/ebsustst/inst/apps/EBSUSTST_ebstestapp/ora/10.1.3/j2ee/oacore/application-deploymen
ts/oacore/orion-application.xml

E) Bounced OACORE and Apache

F) Upon finishing the Configuration, the message "please wait while the configuration saves" message is displayed but does not complete.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms