My Oracle Support Banner

The 19.2.0.2.0 OBDX Mobile Application Is Build Failed In The Android Workspace. (Doc ID 2717966.1)

Last updated on JUNE 16, 2021

Applies to:

Oracle Banking Digital Experience - Version 19.2.0.0.0 and later
Information in this document applies to any platform.

Symptoms

When a retailer/corporate user attempting to build the .apk file from the 19.2.0.2.0 Android workspace by following the OTN document
the following error occurs.

ERROR
-----------------------
Error: Manifest merger failed : Attribute meta-data#android.support.VERSION@value value=(26.0.2) from [com.android.support:percent:26.0.2] AndroidManifest.xml:25:13-35
is also present at [com.android.support:support-v4:26.1.0] AndroidManifest.xml:28:13-35 value=(26.1.0).
Suggestion: add 'tools:replace="android:value"' to element at AndroidManifest.xml:23:9-25:38 to override.


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Android workspace build by a retailer/corporate user
2. Before generating the ..apk file, at the time of building the application, the exception will be displayed.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.