Oracle VM: Upgrade From 3.1.1 to 3.3.4 Using "UpgradeServers.py" Script Fails With "OVMAPI_6000E Internal Error: String index out of range: -1" (Doc ID 2147511.1)

Last updated on JUNE 15, 2016

Applies to:

Oracle VM - Version 3.1.1 to 3.1.1 [Release OVM31]
Information in this document applies to any platform.

Symptoms

Upgrading Oracle VM Server (OVS) 3.1.1 build 612 to 3.3.4 via 2 YUM repositories, the script "UpgradeServers.py" fails with:

Changes

N/A

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms