My Oracle Support Banner

Unable to Mount Repository to OVM Server with Error "Unable to mount file system "/dev/mapper/36xxxxxxxxxx": mount: you must specify the filesystem type\n" (Doc ID 2163873.1)

Last updated on AUGUST 04, 2018

Applies to:

Oracle VM - Version 3.2.9 and later
Linux x86-64

Symptoms

Unable to mount repository to OVM server in OVM manager GUI, the job details shows below error:

Starting operation 'File System Mount Construct' on object '4c:4c:45:44:00:43:4d:10:80:52:b5:c0:4f:59:43:32_mount_/OVS/Repositories/0004fb00000300009947d9ea2c891c94 (ovm05_/OVS/Repositories/0004fb00000300009947d9ea2c891c94)'
Job Internal Error (Operation)com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_B000E Storage plugin command [storage_plugin_mount] failed for storage server [0004fb0000090000f27b520816fce622] failed with [com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_4010E Attempt to send command: dispatch to server: ovm05 failed. OVMAPI_4004E Server Failed Command: dispatch https://?uname?:?pwd?@X.X.X.X:8899/api/3 storage_plugin_mount oracle.ocfs2.OCFS2.OCFS2Plugin /OVS/Repositories/0004fb00000300009947d9ea2c891c94 true [], Status: OSCPlugin.OperationFailedEx:'Unable to mount file system "/dev/mapper/360050763008101e80000000000000006": mount: you must specify the filesystem type\n' OVMAPI_4010E Attempt to send command: dispatch to server: ovm05 failed. OVMAPI_4004E Server Failed Command: dispatch https://?uname?:?pwd?@X.X.X.X:8899/api/3 storage_plugin_mount oracle.ocfs2.OCFS2.OCFS2Plugin /OVS/Repositories/0004fb00000300009947d9ea2c891c94 true [], Status: org.apache.xmlrpc.XmlRpcException: OSCPlugin.OperationFailedEx:'Unable to mount file system "/dev/mapper/360050763008101e80000000000000006": mount: you must specify the filesystem type\n'

And ovs-agent log shows the following error:

RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: ovm_repo. Please verify its path and try again
[2016-04-14 13:54:40 9272] ERROR (service:96) catch_error: Cannot retrieve repository metadata (repomd.xml) for repository: ovm_repo. Please verify its path and try again
Traceback (most recent call last):
File "/usr/lib64/python2.4/site-packages/agent/lib/service.py", line 94, in wrapper
return func(*args)
File "/usr/lib64/python2.4/site-packages/agent/api/host/linux.py", line 195, in yum_list_package
ygh = yb.doPackageLists(pkgnarrow, patterns, showdups, ignore_case)
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 1654, in doPackageLists
for (n,a,e,v,r) in self.up.getUpdatesList():
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 675, in <lambda>
up = property(fget=lambda self: self._getUpdates(),
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 559, in _getUpdates
self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 662, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 502, in _getSacks
self.repos.populateSack(which=repos)
File "/usr/lib/python2.4/site-packages/yum/repos.py", line 260, in populateSack
sack.populate(repo, mdtype, callback, cacheonly)
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 168, in populate
if self._check_db_version(repo, mydbtype):
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 226, in _check_db_version
return repo._check_db_version(mdtype)
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1226, in _check_db_version
repoXML = self.repoXML
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1399, in <lambda>
repoXML = property(fget=lambda self: self._getRepoXML(),
File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1395, in _getRepoXML
raise Errors.RepoError, msg
RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: ovm_repo. Please verify its path and try again
[2016-04-14 16:34:44 15259] INFO (storageplugin:109) storage_plugin_mount(oracle.ocfs2.OCFS2.OCFS2Plugin)
[2016-04-14 16:34:45 15259] ERROR (OCFS2:234) Unable to mount file system "/dev/mapper/360050763008101e80000000000000006": mount: you must specify the filesystem type

[2016-04-14 16:34:45 15259] INFO (storageplugin:125) Exception: 'Unable to mount file system "/dev/mapper/360050763008101e80000000000000006": mount: you must specify the filesystem type\n'

Manually mount the repository to OVM server with the following error:

# mount -t ocfs2 /dev/mapper/360050763008101e80000000000000006 /OVS/Repositories/0004fb00000300009947d9ea2c891c94
mount.ocfs2: Bad magic number in superblock while opening device /dev/mapper/360050763008101e80000000000000006

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.