My Oracle Support Banner

yum update will not run - error: optparse.OptionConflictError: option --downloadonly: conflicting option string(s): --downloadonly (Doc ID 2169949.1)

Last updated on AUGUST 04, 2018

Applies to:

Linux OS - Version Oracle Linux 6.0 and later
Information in this document applies to any platform.
yum was previously being run and it was aborted. Even after running "yum clean all" the yum process still will not run.

Symptoms

 When trying to run "yum update", it aborts with a stack trace ending with the message "error: optparse.OptionConflictError: option --downloadonly: conflicting option string(s): --downloadonly"

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.