My Oracle Support Banner

OL: Lock To Specific RPM Package Version Or Block RPM Package Updates (Doc ID 2305715.1)

Last updated on AUGUST 04, 2018

Applies to:

Linux OS - Version Oracle Linux 5.0 to Oracle Linux 7.4 with Unbreakable Enterprise Kerne [4.1.12] [Release OL5 to OL7U4]
Information in this document applies to any platform.

Goal

 This document helps in restricting yum to install or upgrade a package to a specific version and not to a later version than specified and also to lock the package to the specific version from the update.

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
 Oracle Linux 5
 Oracle Linux 6 And Later
  Install the yum-plugin-versionlock RPM package.
 How to block further updates to an RPM package
 Display the blocked RPM names
 Resume updating blocked RPM packages


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.