Dependency errors while trying to install 32 bit glibc-devel package glibc-devel-2.12-1.209.0.3.el6_9.2.i686.rpm

(Doc ID 2316378.1)

Last updated on OCTOBER 12, 2017

Applies to:

Linux OS - Version Oracle Linux 6.9 with Unbreakable Enterprise Kernel [3.8.13] to Oracle Linux 7.4 with Unbreakable Enterprise Kerne [4.1.12] [Release OL6U9 to OL7U4]
Information in this document applies to any platform.

Symptoms

Attempting to install the 32 bit glibc package on OL6.X uek3 kernel fails with the following errors:

#yum install glibc-devel.i686
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.i686 0:2.12-1.209.0.3.el6_9.1 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.209.0.3.el6_9.1 for package: glibc-devel-2.12-1.209.0.3.el6_9.1.i686
--> Processing Dependency: glibc = 2.12-1.209.0.3.el6_9.1 for package: glibc-devel-2.12-1.209.0.3.el6_9.1.i686
--> Finished Dependency Resolution
Error: Package: glibc-devel-2.12-1.209.0.3.el6_9.1.i686 (local_ol6_latest)
Requires: glibc = 2.12-1.209.0.3.el6_9.1
Installed: glibc-2.12-1.209.0.3.el6_9.2.i686 (@public_ol6_latest)
glibc = 2.12-1.209.0.3.el6_9.2
Available: glibc-2.12-1.166.el6_7.3.i686 (local_ol6_latest)
glibc = 2.12-1.166.el6_7.3
Available: glibc-2.12-1.166.el6_7.7.i686 (local_ol6_latest)
glibc = 2.12-1.166.el6_7.7
Available: glibc-2.12-1.209.0.3.el6_9.1.i686 (local_ol6_latest)
glibc = 2.12-1.209.0.3.el6_9.1
Error: Package: glibc-devel-2.12-1.209.0.3.el6_9.1.i686 (local_ol6_latest)
Requires: glibc-headers = 2.12-1.209.0.3.el6_9.1
Installed: glibc-headers-2.12-1.209.0.3.el6_9.2.x86_64 (@public_ol6_latest)
glibc-headers = 2.12-1.209.0.3.el6_9.2
Available: glibc-headers-2.12-1.166.el6_7.3.x86_64 (local_ol6_latest)
glibc-headers = 2.12-1.166.el6_7.3
Available: glibc-headers-2.12-1.166.el6_7.7.x86_64 (local_ol6_latest)
glibc-headers = 2.12-1.166.el6_7.7
Available: glibc-headers-2.12-1.209.0.3.el6_9.1.x86_64 (local_ol6_latest)
glibc-headers = 2.12-1.209.0.3.el6_9.1
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
libgomp-4.4.7-18.el6.x86_64 is a duplicate with libgomp-4.4.4-13.el6.i686

Changes

 Customer is installing the oracle 11.2.0.4 32bit client   after following the document : Requirements for Installing Oracle Database 12.1 on RHEL6 or OL6 64-bit (x86-64) (Doc ID 1529864.1).

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms