Error: Package: spacewalk-java-xx.noarch or spacewalk-taskomatic-xx.noarch

(Doc ID 2335382.1)

Last updated on DECEMBER 04, 2017

Applies to:

Linux OS - Version Oracle Linux 7.0 and later
Information in this document applies to any platform.

Goal

While upgrading spacewalk server runing on OL7 it giving error below:


Error: Package: spacewalk-java-2.6.49-1.0.1.el7.noarch (@ol7_spacewalk26_server)
  Requires: cglib < 2.2
  Removing: cglib-2.1.3-4.jpp5.noarch (@ol7_spacewalk26_server)
  cglib = 2.1.3-4.jpp5
  Updated By: cglib-2.2-18.el7.noarch (ol7_optional_latest)
  cglib = 2.2-18.el7
Error: Package: spacewalk-taskomatic-2.6.49-1.0.1.el7.noarch (@ol7_spacewalk26_server)
  Requires: cglib < 2.2
  Removing: cglib-2.1.3-4.jpp5.noarch (@ol7_spacewalk26_server)
  cglib = 2.1.3-4.jpp5
  Updated By: cglib-2.2-18.el7.noarch (ol7_optional_latest)
  cglib = 2.2-18.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms