Oracle Linux Upgrade Fails with Dependency Resolution Errors

(Doc ID 2347350.1)

Last updated on FEBRUARY 15, 2018

Applies to:

Linux OS - Version Oracle Linux 6.2 with Unbreakable Enterprise Kernel [2.6.32] and later
Linux x86-64

Symptoms

When running a YUM update to update your system or even updating in an attempt to jump to a newer release( For ex:  from Oracle Linux 6.2 to 6.9),

the operations ends with a list of broken or missing dependency packages as shown below:

#yum update
--> Finished Dependency Resolution
Error: Package: mpitests_mvapich2__1_9-3.2.6-e958579.x86_64 (installed)
Requires: libmpich.so.10()(64bit)
Removing: mvapich2-1.9-1.x86_64 (installed)
libmpich.so.10()(64bit)
Updated By: mvapich2-2.0rc1-1.el6.x86_64 (ol6_latest)
Not found
Error: Package: libmlx4-devel-1.0.4mlnx2-OFED.2.1.192.ge3db542.x86_64 (installed)
Requires: libmlx4 = 1.0.4mlnx2-OFED.2.1.192.ge3db542
Removing: libmlx4-1.0.4mlnx2-OFED.2.1.192.ge3db542.x86_64 (installed)
libmlx4 = 1.0.4mlnx2-OFED.2.1.192.ge3db542
Updated By: libmlx4-1.0.6-7.el6.x86_64 (ol6_latest)
libmlx4 = 1.0.6-7.el6
Available: libmlx4-1.0.1-7.el6.i686 (ol6_latest)
libmlx4 = 1.0.1-7.el6
Available: libmlx4-1.0.2-3.el6.i686 (ol6_latest)
libmlx4 = 1.0.2-3.el6
Available: libmlx4-1.0.2-5.el6.i686 (ol6_latest)
libmlx4 = 1.0.2-5.el6
Available: libmlx4-1.0.4-1.el6.i686 (ol6_latest)
libmlx4 = 1.0.4-1.el6
Available: libmlx4-1.0.5-4.el6.1.i686 (ol6_latest)
libmlx4 = 1.0.5-4.el6.1
Available: libmlx4-1.0.6-6.el6.i686 (ol6_latest)
libmlx4 = 1.0.6-6.el6
Error: Package: libmlx5-devel-1.0.0-OFED.2.1.192.g1cedc9a.x86_64 (installed)
Requires: libmlx5 = 1.0.0-OFED.2.1.192.g1cedc9a
Removing: libmlx5-1.0.0-OFED.2.1.192.g1cedc9a.x86_64 (installed)
libmlx5 = 1.0.0-OFED.2.1.192.g1cedc9a
Updated By: libmlx5-1.0.2-1.el6.x86_64 (ol6_latest)
libmlx5 = 1.0.2-1.el6
Available: libmlx5-1.0.1-1.el6.x86_64 (ol6_latest)
libmlx5 = 1.0.1-1.el6
Error: Package: libnes-devel-static-1.1.3mlnx1-OFED.2.0.2.6.3.1.gae2c5c5.x86_64 (installed)
Requires: libnes = 1.1.3mlnx1-OFED.2.0.2.6.3.1.gae2c5c5
Removing: libnes-1.1.3mlnx1-OFED.2.0.2.6.3.1.gae2c5c5.x86_64 (installed)
libnes = 1.1.3mlnx1-OFED.2.0.2.6.3.1.gae2c5c5
Updated By: libnes-1.1.4-2.el6.x86_64 (ol6_latest)
libnes = 1.1.4-2.el6
Available: libnes-1.1.1-1.el6.x86_64 (ol6_latest)
libnes = 1.1.1-1.el6
Available: libnes-1.1.1-2.el6.x86_64 (ol6_latest)
libnes = 1.1.1-2.el6
Available: libnes-1.1.3-1.el6.x86_64 (ol6_latest)
libnes = 1.1.3-1.el6
Available: libnes-1.1.4-1.el6.x86_64 (ol6_latest)
libnes = 1.1.4-1.el6
You could try using --skip-broken to work around the problem

 

Changes

None

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms