Oracle Openstack 4.0.1: Yum Installation of openstack-kolla RPMs Fails with Dependencies issue

(Doc ID 2354054.1)

Last updated on FEBRUARY 08, 2018

Applies to:

Oracle OpenStack for Oracle Linux - Version OpenStack 4.0.1 and later
Linux x86-64

Symptoms

When try to install openstack-kolla RPMs, yum transaction prompts dependencies error, for instance:


# yum install openstack-kolla-preinstall
Loaded plugins: ulninfo
Resolving Dependencies
--> Running transaction check
---> Package openstack-kolla-preinstall.noarch 0:4.0.1-2.el7 will be installed
--> Processing Dependency: docker-engine = 1.12.6 for package: openstack-kolla-preinstall-4.0.1-2.el7.noarch
--> Finished Dependency Resolution
Error: Package: openstack-kolla-preinstall-4.0.1-2.el7.noarch (ol7_openstack40)
Requires: docker-engine = 1.12.6
Installed: docker-engine-17.06.2.ol-1.0.1.el7.x86_64 (@ol7_addons)
docker-engine = 17.06.2.ol-1.0.1.el7
Available: docker-engine-1.8.2-1.0.2.el7.x86_64 (ol7_addons)
docker-engine = 1.8.2-1.0.2.el7
Available: docker-engine-1.8.3-1.0.1.el7.x86_64 (ol7_addons)
docker-engine = 1.8.3-1.0.1.el7
Available: docker-engine-1.8.3-1.0.2.el7.x86_64 (ol7_addons)
docker-engine = 1.8.3-1.0.2.el7
Available: docker-engine-1.9.1-1.0.1.el7.x86_64 (ol7_addons)
docker-engine = 1.9.1-1.0.1.el7
Available: docker-engine-1.10.3-1.0.1.el7.x86_64 (ol7_addons)
docker-engine = 1.10.3-1.0.1.el7
Available: docker-engine-1.10.3-1.0.2.el7.x86_64 (ol7_addons)
docker-engine = 1.10.3-1.0.2.el7
Available: docker-engine-1.10.3-1.0.3.el7.x86_64 (ol7_addons)
docker-engine = 1.10.3-1.0.3.el7
Available: docker-engine-1.12.0-1.0.2.el7.x86_64 (ol7_addons)
docker-engine = 1.12.0-1.0.2.el7
Available: docker-engine-1.12.2-1.0.1.el7.x86_64 (ol7_addons)
docker-engine = 1.12.2-1.0.1.el7
Available: docker-engine-1.12.6-1.0.1.el7.x86_64 (ol7_addons)
docker-engine = 1.12.6-1.0.1.el7
Available: docker-engine-1.12.6-1.0.3.el7.x86_64 (ol7_addons)
docker-engine = 1.12.6-1.0.3.el7
Available: docker-engine-17.03.1.ce-3.0.1.el7.x86_64 (ol7_addons)
docker-engine = 17.03.1.ce-3.0.1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms