My Oracle Support Banner

Cannot Update Kernel-uek Package with rpm Commands (Doc ID 2368555.1)

Last updated on MAY 13, 2020

Applies to:

Oracle Cloud Infrastructure - Version N/A and later
Linux OS - Version Oracle Linux 7.2 with Unbreakable Enterprise Kernel [4.1.12] and later
Linux x86-64

Symptoms

When attempting to  update kernel-uek package using the rpm command, the following dependency error is received:


[root@hostname]# uname
Linux hostname.example.com 4.1.12-61.1.18.el7uek.x86_64 #2 SMP Fri Nov 4 15:48:30 PDT 2016 x86_64 x86_64 x86_64 GNU/Linux

[root@hostname]# rpm -ivh --test kernel-uek-firmware-4.1.12-112.14.15.el7uek.noarch.rpm kernel-uek-4.1.12-112.14.15.el7uek.x86_64.rpm
error: Failed dependencies:
  linux-firmware >= 20171128-57.git17e62881.0.2 is needed by kernel-uek-4.1.12-112.14.15.el7uek.x86_64

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.