My Oracle Support Banner

Oracle VM: discover_repositories Fails with "Not a directory" (Doc ID 2431720.1)

Last updated on JULY 14, 2020

Applies to:

Private Cloud Appliance - Version 2.3.3 and later
Oracle VM - Version 3.4.1 and later
Linux x86-64

Symptoms

Refresh repository failed, and running VM became ORPHAN.

Oracle VM Manger logs show below error:

####<2018-06-05T19:03:05.664+0000> <> <> <4da2e401-4e87-4d05-9a5f-a3d86e4a5f55-00000004> command: discover_repositories to server: ovs-server failed. OVMAPI_4004E Sync command failed on server:x.x.x.x. Command: discover_repositories, Server error: org.apache.xmlrpc.Xm
lRpcException: <type 'exceptions.OSError'>:[Errno 20] Not a directory: '/OVS/Repositories/xxxx/VirtualMachines/image_files.tar' [Tue Jun 05 19:03:05 UTC 2018]
com.oracle.ovm.mgr.api.exception.FailedOperationException: OVMAPI_4010E Attempt to send command: discover_repositories to server: ovs-server failed. OVMAPI_4004E Sync command failed on server: x.x.x.x. Command: discover_repositories,

Server error: org.apache.xmlrpc.XmlRpcException: <type 'exceptions.OSError'>:[Errno 20] Not a directory: '/OVS/Repositories/xxxx/VirtualMachines/image_files.tar'

 

 

Changes

 
there is manually created file image_files.tar in repository .

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.