My Oracle Support Banner

yum upgrade of setup package failed with error: unpacking of archive failed on file /etc/shadow.rpmnew: cpio: rename (Doc ID 2481805.1)

Last updated on APRIL 24, 2020

Applies to:

Linux OS - Version Oracle Linux 7.6 with Unbreakable Enterprise Kernel [4.14.35] and later
Linux x86-64

Symptoms

The customer was using yum to update their Oracle Linux 7 system, however updating the setup.noarch package failed with the following error:


# yum update setup.noarch
  Updating : setup-2.8.71-10.el7.noarch 1/2
Error unpacking rpm package setup-2.8.71-10.el7.noarch
error: unpacking of archive failed on file /etc/shadow.rpmnew: cpio: rename
  Verifying : setup-2.8.71-10.el7.noarch 1/2
setup-2.8.71-9.el7.noarch was supposed to be removed but is not!
  Verifying : setup-2.8.71-9.el7.noarch 2/2

Failed:
  setup.noarch 0:2.8.71-9.el7 setup.noarch 0:2.8.71-10.el7



Trying to install or update the rpm package directly also failed similarly.

Changes

 3rd party security software had been recently been installed for testing purposes on the server with this issue.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.