My Oracle Support Banner

Oracle Linux: Yum Update Failed with Glibc Dependency Error (Doc ID 2613180.1)

Last updated on NOVEMBER 21, 2019

Applies to:

Linux OS - Version Oracle Linux 7.0 and later
Linux x86-64

Symptoms

#yum update glibc.i686

Loaded plugins: langpacks, ulninfo

Resolving Dependencies

--> Running transaction check

---> Package glibc.i686 0:2.17-260.0.15.el7_6.5 will be updated

---> Package glibc.i686 0:2.17-292.0.1.el7 will be an update

--> Processing Dependency: glibc-common = 2.17-292.0.1.el7 for package: glibc-2.17-292.0.1.el7.i686

--> Running transaction check

---> Package glibc-common.x86_64 0:2.17-260.0.15.el7_6.5 will be updated

 

..

..

--> Running transaction check

---> Package glibc-static.x86_64 0:2.17-260.0.15.el7_6.5 will be updated

---> Package glibc-static.x86_64 0:2.17-260.0.17.el7_6.6 will be an update   <<<<<<  this is not the latest 

--> Processing Dependency: glibc-devel = 2.17-260.0.17.el7_6.6 for package: glibc-static-2.17-260.0.17.el7_6.6.x86_64

 ..


Error: Package: glibc-devel-2.17-260.0.17.el7_6.6.i686 (local_ol7_6)
  Requires: glibc = 2.17-260.0.17.el7_6.6
  Removing: glibc-2.17-260.0.15.el7_6.5.i686 (@local_ol7_latest)
  glibc = 2.17-260.0.15.el7_6.5
  Updated By: glibc-2.17-292.0.1.el7.i686 (local_ol7_latest)
  glibc = 2.17-292.0.1.el7
  Available: glibc-2.17-55.el7.i686 (local_ol7_latest)



Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.