My Oracle Support Banner

Spacewalk: Upgrade OS Using Spacewalk BUI Remote Commad Results In Duplicates And A Failed Install (Doc ID 2614768.1)

Last updated on DECEMBER 02, 2019

Applies to:

Linux OS - Version Oracle Linux 7.6 and later
Linux x86-64

Symptoms

Unable to perform yum update from Spacewalk "remote command" as it got terminated leaving multiple Duplicate packages, with the below error :
"warning: %postun(osad-5.11.89-1.el7.noarch) scriptlet failed, signal 15"

Changes

 - ULN "ol7_spacewalk27_client" repository on spacewalk server.
- The osad running on client.
- The OSA Status on BUI shows online
- Performed update via Remote command (System-> "NODE" -> Remote Command -> [Below script] -> Schedule)

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.