My Oracle Support Banner

Latest Opensm-libs In UEK4 Repo Conflicts With Latest Oracle-ofed-release Available (Doc ID 2634076.1)

Last updated on FEBRUARY 17, 2020

Applies to:

Linux OS - Version Oracle Linux 7.7 and later
Linux x86-64

Symptoms

A server running Oracle Linux 7 was unable to have the latest update of opensm-libs installed on it, because it conflicted with the latest version of the oracle-ofed-release available for install at the time, oracle-ofed-release-1.0.0-51.el7uek4.x86_64.

When trying to update opensm-libs, the following errors were observed:

# yum --enablerepo=ol7_x86_64_UEKR4_OFED update
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package opensm-libs.x86_64 4:3.3.19-1.0.4.el7uek4 will be updated
--> Processing Dependency: opensm-libs = 4:3.3.19-1.0.4.el7uek4 for package: oracle-ofed-release-1.0.0-51.el7uek4.x86_64
---> Package opensm-libs.x86_64 4:3.3.19-1.0.5.el7uek4 will be an update
--> Finished Dependency Resolution
Error: Package: oracle-ofed-release-1.0.0-51.el7uek4.x86_64 (@ol7_x86_64_UEKR4_OFED)
  Requires: opensm-libs = 4:3.3.19-1.0.4.el7uek4
  Removing: 4:opensm-libs-3.3.19-1.0.4.el7uek4.x86_64 (@ol7_x86_64_UEKR4_OFED)
  opensm-libs = 4:3.3.19-1.0.4.el7uek4
  Updated By: 4:opensm-libs-3.3.19-1.0.5.el7uek4.x86_64 (ol7_x86_64_UEKR4_OFED)
  opensm-libs = 4:3.3.19-1.0.5.el7uek4
  Available: opensm-libs-3.3.21-2.el7.i686 (ol7_x86_64_u7_base)
  opensm-libs = 3.3.21-2.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.