My Oracle Support Banner

OL8 Yum Update from Local uln_mirror Fail in perl-libs Conflict (Doc ID 2636758.1)

Last updated on FEBRUARY 13, 2020

Applies to:

Linux OS - Version Oracle Linux 8.0 and later
Linux x86-64

Symptoms

Oracle Linux 8 and newer release host cannot run yum update successfully from the local uln_mirror server. The error messages are regarding the conflict of the perl-libs packages.

[root@localhost ~]# uname -a
Linux localhost 4.18.0-147.el8.x86_64 #1 SMP Tue Nov 12 11:05:49 PST 2019 x86_64 x86_64 x86_64 GNU/Linux

[root@localhost ~]# cat /etc/oracle-release
Oracle Linux Server release 8.1

[root@localhost ~]# yum repolist
repo id repo name
ol8_appstream Oracle Linux 8 Application Stream (x86_64) <<< AppStream Latest repository channel on local uln_mirror server
ol8_baseos_latest Oracle Linux 8 BaseOS Latest (x86_64)

[root@localhost ~]# yum update
Last metadata expiration check: 0:00:18 ago on Thu 09 Jan 2020 06:29:04 AM CST.
Error:
Problem 1: cannot install both perl-libs-4:5.24.4-403.module+el8+5173+5d54a0c1.x86_64 and perl-libs-4:5.26.3-416.el8.x86_64
- package perl-Algorithm-Diff-1.1903-9.module+el8+5173+5d54a0c1.noarch requires perl(:MODULE_COMPAT_5.24.4), but none of the providers can be installed
- cannot install the best update candidate for package perl-libs-4:5.26.3-416.el8.x86_64
- cannot install the best update candidate for package perl-Algorithm-Diff-1.1903-9.el8.noarch
- package perl-libs-4:5.24.4-404.module+el8.1.0+5399+8245a79b.x86_64 is excluded
Problem 2: package perl-interpreter-4:5.26.3-416.el8.x86_64 requires libperl.so.5.26()(64bit), but none of the providers can be installed
- package perl-interpreter-4:5.26.3-416.el8.x86_64 requires perl-libs(x86-64) = 4:5.26.3-416.el8, but none of the providers can be installed
- cannot install both perl-libs-4:5.24.4-403.module+el8+5173+5d54a0c1.x86_64 and perl-libs-4:5.26.3-416.el8.x86_64
- cannot install both perl-libs-4:5.26.3-416.el8.x86_64 and perl-libs-4:5.24.4-403.module+el8+5173+5d54a0c1.x86_64
- package perl-Archive-Tar-2.30-1.module+el8+5173+5d54a0c1.noarch requires perl(:MODULE_COMPAT_5.24.4), but none of the providers can be installed
- cannot install the best update candidate for package perl-interpreter-4:5.26.3-416.el8.x86_64
- cannot install the best update candidate for package perl-Archive-Tar-2.30-1.el8.noarch
- package perl-libs-4:5.24.4-404.module+el8.1.0+5399+8245a79b.x86_64 is excluded

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.