My Oracle Support Banner

Oracle Linux: Cannot Find dkms Module for Oracle Linux 6 (Doc ID 2638447.1)

Last updated on FEBRUARY 17, 2020

Applies to:

Linux OS - Version Oracle Linux 6.0 and later
Linux x86-64

Symptoms

On a system registered with ULN and latest channels for Oracle Linux 6, the package dkms is not found when trying to install it.

# yum install dkms
Loaded plugins: refresh-packagekit, rhnplugin, security, ulninfo
This system is receiving updates from ULN.
Setting up Install Process
No package dkms available.
Error: Nothing to do

# yum list available dkms
Loaded plugins: refresh-packagekit, rhnplugin, security, ulninfo
This system is receiving updates from ULN.
Error: No matching Packages to list

However, the module is available for Oracle Linux 7 in the EPEL channel

# yum list available dkms
Loaded plugins: langpacks, rhnplugin, ulninfo
This system is receiving updates from ULN.
Available Packages
dkms.noarch                            2.7.1-1.el7                       ol7_x86_64_developer_EPEL


The EPEL repository is neither available on ULN nor Public YUM for Oracle Linux 6.

Changes

System is registered with the following channels:

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.