My Oracle Support Banner

OLVM: Engine-setup Fails with ERROR: Cannot upgrade PostgreSQL automatically - directory of the new version already exists (Doc ID 2680530.1)

Last updated on JULY 10, 2020

Applies to:

Linux OS - Version Oracle Linux 7.7 and later
Linux x86-64

Symptoms

 Engine setup fails with error:-

[root@<manager_x> data.bak]# engine-setup
.
.

          --== DATABASE CONFIGURATION ==--

[WARNING] This release requires PostgreSQL server 10.6 but the engine database is currently hosted on PostgreSQL server 9.5.14.
[ INFO  ] Verifying PostgreSQL SELinux file context rules
[ ERROR ] A data directory for the new PostgreSQL instance already exists, although the engine uses an older version.
         Please verify that it is not needed, remove it, and then run Setup again.
         Alternatively, you can upgrade PostgreSQL manually.
         Location of the new data directory is:
         /var/opt/rh/rh-postgresql10/lib/pgsql/data

[ ERROR ] Failed to execute stage 'Environment customization': Cannot upgrade PostgreSQL automatically - directory of the new version already exists
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20200608153823-6mu5dw.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20200608154019-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.