The up2date Utility Returns "Sysid checksum is incorrect" (Doc ID 805879.1)

Last updated on JANUARY 30, 2016

Applies to:

Linux OS - Version Enterprise Linux 3.8 to Oracle Linux 5.3 [Release RHEL3U8 to OL5U3]
Information in this document applies to any platform.
This problem can occur on any platform.

Symptoms

Running the up2date utility returns the following error:

Sysid checksum is incorrect


A verbose listing from running the command looks like this:

# up2date -vvv --list
D: opening db environment /var/lib/rpm/Packages joinenv
D: opening db index /var/lib/rpm/Packages rdonly mode=0x0
D: locked db index /var/lib/rpm/Packages
D: opening db index /var/lib/rpm/Name rdonly mode=0x0
D: opening db index /var/lib/rpm/Providename rdonly mode=0x0
Error communicating with server. The message was:
Sysid checksum is incorrect
D: closed db index /var/lib/rpm/Providename
D: closed db index /var/lib/rpm/Name
D: closed db index /var/lib/rpm/Packages
D: closed db environment /var/lib/rpm/Packages

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms