E-ELM/IB:IBRK-18 Error for USER_PROFILE/ELM Handler: Update_Person_ID (Doc ID 1146430.1)

Last updated on MAY 26, 2016

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.48 and later
PeopleSoft Enterprise ELS Enterprise Learning Management - Version 9 to 9 [Release 9]
Information in this document applies to any platform.

Symptoms

Tools only upgrade from tools 8.49.23 to 8.50.07 was completed on the ELM 9.0 database.

The SYSAUDIT report showed the errors:

(IBRK-18) : IB Handler referencing invalid App. Class:

Service Operation             Handler Package             Root App                 Class ID
USER_PROFILE            Update_Person_ID          USER_PROFILE      LM_PersonOprid
1 Total Rows

and

(PEOPLECODE-7) Orphan App Pkg PeopleCode - Level 1:
Object Value#            Object Value
1                                USER_PROFILE
2                                LM_PersonOprid
3                                OnExecute

On our ELM 9.0/8.49.23 release the application class is there.


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms