E-WL: WebLogic 10.3.x Continually Logs Message "<BEA-000403> <IOException occurred on socket: Socket...Descriptor not a socket", but Users are not Impacted (Doc ID 1385373.1)

Last updated on MAY 22, 2013

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.51 to 8.52 [Release 8.4]
Information in this document applies to any platform.
***Checked for relevance on 22-May-2013***

Symptoms

The following messages are constantly logged to log file "PIA_weblogic.log":

####<Dec 5, 2011 1:38:40 PM EST> <Error> <Socket> <myserver> <PIA> <[STANDBY] ExecuteThread: '7' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1323110320856> <BEA-000403> <IOException occurred on socket: Socket[addr=/11.222.33.44,port=52226,localport=8004]
java.net.SocketException: recv failed: Descriptor not a socket.
java.net.SocketException: recv failed: Descriptor not a socket
at jrockit.net.SocketNativeIO.readBytesPinned(Native Method)
at jrockit.net.SocketNativeIO.socketRead(SocketNativeIO.java:32)
at java.net.SocketInputStream.socketRead0(SocketInputStream.java)
at java.net.SocketInputStream.read(SocketInputStream.java:129)
at weblogic.socket.SocketMuxer.readFromSocket(SocketMuxer.java:980)
at weblogic.socket.SocketMuxer.readReadySocketOnce(SocketMuxer.java:922)
at weblogic.socket.SocketMuxer.readReadySocket(SocketMuxer.java:888)
at weblogic.socket.JavaSocketMuxer.processSockets(JavaSocketMuxer.java:339)
at weblogic.socket.SocketReaderRequest.run(SocketReaderRequest.java:29)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)


In addition to the above messages,  PIA_weblogic.log also shows an error loading performance pack, when the PIA starts:

####<Dec 3, 2011 5:27:29 PM EST> <Error> <Socket> <myserver> <PIA> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1322951249661> <BEA-000438> <Unable to load performance pack. Using Java I/O instead. Please ensure that wlntio.dll is in: 'D:\WLS1035\WLSERV~1.3\server\bin;C:\Windows\system32;C:\Windows;D:\WLS1035\WLSERV~1.3\server\native\win\x64\;D:\WLS1035\WLSERV~1.3\server\bin;D:\WLS1035\JROCKI~1.0_2\jre\bin;D:\WLS1035\JROCKI~1.0_2\bin;D:/PT8.51\bin\server\winx86;D:/PT8.51\verity\winx86\_nti40\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;.'
>
####<Dec 3, 2011 5:27:29 PM EST> <Info> <Socket> <myserver> <PIA> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1322951249661> <BEA-000447> <Native IO Disabled. Using Java IO.>



Despite the above messages, the users are not reporting issues accessing the PeopleSoft application.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms