E-PUM: Application Change Package For Fin92 Fails To Run If UKE Is Active In The Target Db (Doc ID 1631750.1)

Last updated on OCTOBER 16, 2014

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.53 to 8.53 [Release 8.4]
Information in this document applies to any platform.

Goal

PT853.09/ Fin92 on Oracle 12c. Install langs for FIn92: Eng and Canadian French
We need UKE (UKEnglish) activated at the ptools level for UK browser support (otherwise UK users get an error and they cannot login to the browser). So we need UKE set to Installed in the pslanguages table.
When defining a change package, the process detects UKE and thinks it is an application lang, which it is not (it is a tools lang). It then includes AE processes for UKE, which fail, as there are no fin92 translated objects for UKE. According to resolution 1615023.1, it should be enough to turn off UKEnglish in the international settings of the PUM image, then reboot the virtual box hosting this, and clean out the directories and files in the EM agents, CA and hub being used. This does not work. After following the above steps, UKE was still detected when defining a change package.
The only way to get round this is to turn UKE off in our target systems by setting installed to 0 for UKE in the psinstallation table with SQL. We should not be need to turn languages we need in our system off for the new process for applying application changes to work correctly. How can this be resolved?
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms