When using a SmartHire template with two components of pay, error occurs: "The highlighted field is required...COMP_RATECD (15, 54) (Doc ID 1923549.1)

Last updated on JULY 13, 2016

Applies to:

PeopleSoft Enterprise HRMS Human Resources - Version 9.2 to 9.2 [Release 9]
Information in this document applies to any platform.

Symptoms


When you hire an employee using a SmartHire template containing a section to accommodate two components of pay, that is effective on the current date, the following error occurs:
  
"The highlighted field is required.You must enter a value before proceeding HCR_JOB_DATA_EMP_SRV.JOB(1).COMPENSATION(1).COMP_RATECD( (15, 54)-- The specified field is required but doesn't have a value"

The issue does not happen if the effective date is future or past.

 
REPLICATION STEPS:
-----------------------

1. Create a SmartHire template having a second section for component of pay, with all defaults the same as the existing component of pay.
2. Hire an employee using this template with effective date the current date.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms