EEX 9.1/9.2: Getting Error 'No Matching Buffer Found' When Submitting a Copied Expense Report After Adding an Attachment

(Doc ID 1924868.1)

Last updated on JULY 07, 2017

Applies to:

PeopleSoft Enterprise FIN Expenses - Version 9.1 to 9.2 [Release 9]
PeopleSoft Enterprise FIN Expenses Argentina - Version 9.1 to 9.1 [Release 9]
Information in this document applies to any platform.

Symptoms

When attempting to submit an Expense Report after adding an attachment to an Expense Report which is copied from another Expense Report, system throws an error.

Steps:
--------
1. Log in as a User.
2. Create an Expense Report by copying an existing Expense Report.
3. Add an attachment to the Expense Line.
4. Now try to submit the Expense Report.

ERROR
-----------------------
No matching buffer found for level. (15,26)

When retrieving data for a page, a data value was retrieved for which there was no matching data value at a higher level scroll entry. (For example, at scroll level 2, a value of ABC was read in and scroll level 1 contained this higher level field but did not have a row with a key value of ABC.) This usually occurs because of an error in a database record or view; or because of improper deletion of values in a database. Correct the page definition or contact your system administrator.


To gather more information concerning this scenario and its related problem, refer to the available Replication Steps containing the complete configuration and the replication steps necessary to reproduce the issue.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms