E-AD: Earlier Patch Levels 8.52/8.53/8.54 Cannot Login To Database/Appserver On Patches 8.52.24, 8.53.17, 8.54.04+ (Doc ID 1958693.1)

Last updated on DECEMBER 30, 2016

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.52 and later
Information in this document applies to any platform.

Symptoms

In the past, Application Designer was able to login to the database even if it was running different a minor patch level compared to the database.  However, after upgrading to patches on 8.52.24, 8.53.17, or 8.54.04 or higher on the database side, earlier minor patch level Application Designer is no longer able to login.

In other words:
- 8.52.23 or lower App Designer is no longer able to connect to DBs on 8.52.24 or higher
- 8.53.16 or lower App Designer is no longer able to connect to DBs on 8.53.17 or higher
- 8.54.03 or lower App Designer is no longer able to connect to DBs on 8.54.04 or higher

Vice Versa:
- 8.52.24 or higher App Designer is no longer able to connect to DBs on 8.52.23 or lower
- 8.53.17 or higher App Designer is no longer able to connect to DBs on 8.53.16 or lower
- 8.54.04 or higher App Designer is no longer able to connect to DBs on 8.54.03 or lower

The error is "Invalid Access ID and password for signon" or "Invalid User ID and password for signon", or at the trace level "ORA-01017: invalid username/password; logon denied" etc.

The evidence in a SQL Trace would be an Access ID with garbled characters, meaning the client could not properly decrypt the Access ID data from PSACCESSPRFL:

For example:

1-260    09.55.09    0.000000 Cur#0.14072.HR92DMO RC=404 Dur=0.030000 Create Connection Info=Primary/HR92DMO/Ýjsé\ãBì/ Handle=0000000000000000

The problem affects all PeopleSoft client programs, including Application Designer, DataMover, Query, etc.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms