My Oracle Support Banner

E-WL: Frequently Asked Questions about Upgrading WebLogic 12c for PeopleTools 8.54 and 8.55 to a Newer Patch Set Update (PSU), Release, and/or a Newer Java Patch Level (Doc ID 1987310.1)

Last updated on JANUARY 11, 2018

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.54 and later
Information in this document applies to any platform.

Purpose

This document answers frequently asked questions regarding:
  1) Steps to Upgrading WebLogic to a newer Patch Set Update (PSU) and Release level
  2) Questions about Upgrading Java patch level for your WebLogic Install.
  3) Details on how to locate/download/install newer WebLogic Patch Set Updates (PSU's), Releases and Java Patches

This document is specifically for PeopleTools 8.54 and 8.55 environments which are using WebLogic 12c.

Questions and Answers

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Questions and Answers
 Give me an overview of the steps to get updated to the latest WebLogic version and patch level. Also, explain the difference between Releases and Patch Set Updates
 Give me the step-by-step details for Upgrading WebLogic 12.1.x to the latest Release Level, Patch Level and Java Patch Level.
 How can I tell what WebLogic Release / Patch Set Update and Java patch# that I'm currently using?
 Do I need to re-install the WebLogic PIA(s) after completing a WebLogic Upgrade?
 How can I validate that the WebLogic upgrade was successful?
 Do all PeopleTools 8.5x Environments use the same WebLogic Version and Java Version? And can I upgrade my existing PeopleTools Environment to a newer Weblogic Version (eg WebLogic to WebLogic 12c) or a Newer Java Version (eg JDK 6 to JDK 7)?
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.