Attachment Issue In Supplier Registration Process When Multiple Attachments Are Uploaded (Doc ID 2007035.1)

Last updated on DECEMBER 13, 2016

Applies to:

PeopleSoft Enterprise SCM Purchasing - Version 9.2 and later
Information in this document applies to any platform.

Symptoms

On : 9.2 version, Supplier/User Maintenance

ACTUAL BEHAVIOR
---------------
Attachment Issue in Supplier registration process when multiple attachments are uploaded.


EXPECTED BEHAVIOR
-----------------------
Attachment should not be deleted

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1)  Setup the Supplier Registration Template with two profile questions requiring attachments.
2)  Register supplier (Suppliers > Supplier Registration > Register Suppliers)
3)  Upload first attachment
4)  Upload second attachment (Note that the first attachment appears on the page, so user must add a new row)
5)  At this point the first question shows as: View/Modify Attachment (1) and the second question shows as: View/Modify Attachment (2).  They should both display as View/Modify Attachment (1) since each question has 1 attachment.
6)  Go to Manage Request Approval page and see that both questions show Attachment Exist.
7)  Click the Attachment link for the first question.  See that no attachment appears.  If I hit Return, nothing happens (it does not return me to the Review Page).  I have to hit the ‘X’ to return to the Review Page.
8)  Click the Attachment link for the second question and it has the same problem as the first attachment.
BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users cannot register suppliers with required information.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms