My Oracle Support Banner

What Security is Required to Build Rule in the Rules Engine Manager to Avoid Error - Failed to Build : SCC_RULE_ID_... - APPLICATION_PACKAGE is Not an Object Type That You are Authorized to Update. (78,34)? (Doc ID 2260981.1)

Last updated on FEBRUARY 16, 2018

Applies to:

PeopleSoft Enterprise CS Campus Community - Version 9 and later
Information in this document applies to any platform.

Goal

What security is required to build Rules Engine rules?  The following error is encountered:

Failed to build : SCC_RULE_ID_[Rule ID] - APPLICATION_PACKAGE is not an object type that you are authorized to update. (78,34) (2,-1)
SCC_COMMON_UTILITIES.UTIL.AppClassCompiler854.OnExecute Name:compileProgram PCPC:7747 Statement:136
Called from:SCC_COMMON_UTILITIES.UTIL.AppClassCompiler854.OnExecute Name:compile Statement:115
Called from:SCC_RULES_ENGINE.Components.SCC_RULE_BUILDER.SCC_RULE_BUILDER.OnExecute Name:SCC_RULE_BD_WRK_SCC_RULE_BLD_BTN_FieldChange Statement:94
Called from:SCC_RULE_BUILDER.GBL.SCC_RULE_BD_WRK.SCC_RULE_BLD_BTN.FieldChange Statement:1

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.