My Oracle Support Banner

EAM: PS_ASSET_ALL_VW Is Not Updated When Assets Uploaded Via Excel To CI (Doc ID 2435845.1)

Last updated on AUGUST 15, 2018

Applies to:

PeopleSoft Enterprise FIN Asset Management - Version 9.1 and later
Information in this document applies to any platform.

Goal

When loading assets that have no locations and/or custodian values via the Excel To CI Templates, the ps_asset_all_vw view does not get updated after AMIF1000 runs because the sql view contains joins between ps_asset, ps_asset_custodian and ps_asset_location and the ps_asset_custodian and ps_asset_location tables are not created for the asset. However, if you enter an asset via Express Add that does not have location and/or custodian values, ps_asset_all_vw does update with the asset created because rows in the ps_asset_custodian and ps_asset_location tables are created. If you manually update the Excel To CI Template with a location and/or custodian value for the asset, ps_asset_all_vw is updated as the rows in the requisite tables are created.

This is causing a reporting issue as the AM report retrieves data from ps_asset_all_vw and ps_dist_ln.  Assets are missing from ps_asset_all_vw.  Therefore, the report is incorrect.  

Is this the normal behavior when the Excel to CI upload is used vs. entering asset online?

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.