My Oracle Support Banner

E-PORTAL: Issues Utilizing Third Party SSO Across PeopleSoft Applications 8.54,8.55 And 8.56. (Doc ID 2453363.1)

Last updated on NOVEMBER 23, 2020

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.55 and later
Information in this document applies to any platform.

Symptoms

After upgrade to PT 8.55.16, issues are occuring in regards with PeopleSoft single signon between two PeopleSoft systems. This issue occurs with external third party single signon implemented. For this example, we will use the SSO between HCM 9.2 (PT 8.55.16) and CS 9.0 (PT 8.54.30). Both environments have InPortalContext set to false on the web profile.

Scenario 1:

User logins to HCM 9.2 using 3rd party login.

Login is successful and user is redirected to NUI/Fluid Landing Page (NUI_FRAMEWORK.PT_LANDINGPAGE).

User navigates to custom Portal.

User deep-links to CS 9.0 Default Classic Homepage (/h/?tab=DEFAULT).

User is kicked out of CS and user’s session is no longer valid.

PSAPPSRV.26647 (9413) [2017-07-19T13:48:54.828 *********** (CHROME 59.0.3071.115; WIN7) HomepageTemplate](1) Error in service HomepageT, CREF with URL can not be found: /psc/sdevcs/EMPLOYEE/HRMS/?tab=DEFAULT

PSAPPSRV.26647 (9413) [2017-07-19T13:48:54.828 *********** (CHROME 59.0.3071.115; WIN7) HomepageTemplate](1) (NET.346): Failed to execute HomepageTemplate request

PSAPPSRV.26647 (9413) [2017-07-19T13:48:54.829 ***********](2) Service HomepageT failed

Scenario 2:

User logins to CS 9.0 using 3rd party login.

Login is successful and user is redirected to Default Classic Homepage (/h/?tab=DEFAULT).

User navigates to custom Portal.

User deep-links to HCM 9.2 NUI/Fluid Landing Page (NUI_FRAMEWORK.PT_LANDINGPAGE).

User session switches to the default “Public User” on the web profile.

After reviewing the following document on MOS:

E-PORTAL: Macro Set Changes Not Displayed After Being Applied to Branding Theme (Doc ID 2191176.1)

The SSO works if the following is used as the landing page URL:

/s/WEBLIB_PTBR.ISCRIPT1.FieldFormula.IScript_StartPage

But there are still issues with login/deep-link directly to /psc/ URLs. According to Doc ID 2191176.1:

“However, for fluid components, or any direct psc URL pages, they will NOT get the proper ps_theme cookie until the page is refreshed or move to a different page. That particular problem is handled by Bug 24738007 - ICONS IN FLUID HEADER INVISIBLE WHEN LOGGING IN THROUGH DEEPLINK”

This does not appear to be the case. On 8.55.16, the issue persists for /psc/ deep link URLs.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.