My Oracle Support Banner

E-PIA: Webserver cannot be accessed using Chrome or Firefox or in the Chromium based Edge - when using SSL after Webserver is restarted displays error message "err_connection_closed" (Doc ID 2711676.1)

Last updated on OCTOBER 19, 2020

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.56 to 8.58 [Release 8.4]
Information in this document applies to any platform.

Symptoms

The Webserver cannot be accessed using Chrome or Firefox or in Chromium based Edge using SSL after applying recent weblogic and/or java patches being applied

The same SSL works always fine in IE 11 and, as well always works if lets say Fiddler is used as an SSL proxy to access PIA in SSL and collect http traces.

This is due to a conflict between the Bouncy Castle libraries delivered by PeopleTools and this newest JDK version 1.8.0_261++ used by weblogic SSL handling
Weblogic SSL access can be restored temporarily by a PIA bounce, however the SSL access will stop working after a while, on a particular IB http request being done against the WebLogic server.

Webserver is restarted and again displays message "err_connection_closed" however it works fine in IE. 

 

Changes

This issue began after implementing the July 2020 CPU Java and Weblogic patches

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.