My Oracle Support Banner

E-WL: After Booting The WebLogic Domain PeopleSoft Is Not Accessible Returning Message, "Error 404--Not Found" (Doc ID 2995742.1)

Last updated on JANUARY 05, 2024

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.57 and later
Information in this document applies to any platform.

Symptoms

In PeopleTools 8.54.* and higher versions after booting the Weblogic domain, PeopleSoft PIA login page is not available returning following error message:


- Error 404--Not Found

- The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

Into "PIA_WebLogic" file located under, <PIA_HOME>/webserv/<DOMAIN-NAME>/servers/PIA/logs/PIA_Weblogic.log the following error message was returned:

- <Error> <Deployer> <gtret-conla01p.nam.nsroot.net> <PIA> <[STANDBY] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <> <[severity-value: 8] [rid: 0] [partition-id: 0] [partition-name: DOMAIN] > <BEA-149205> <Failed to initialize the application "peoplesoft" due to error java.lang.RuntimeException: Found NULL source URL for source <------------- /PORTAL.war/ ------------->
at weblogic.application.metadatacache.ClassesMetadataEntry.isStale(ClassesMetadataEntry.java:160)

After rebooting the web server domain users were not able to login into PeopleSoft PIA page.

Changes

A soft link was created at web server level in "Portal.war" file.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.