E-IB: Getting "UserName not defined in database" When Testing Component Interface Based Web Service (Doc ID 653500.1)

Last updated on JUNE 09, 2015

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.4 and later
Information in this document applies to any platform.
***Checked for relevance on 09-JUN-2015***

Symptoms

When testing a Component Interface based web service from SendMaster utility or when trying to view the WSDL by accessing the WSDL URL in a browser, receive an error like the following:

<?xml version="1.0" ?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>null</faultstring><detail><IBResponse type="error"><DefaultTitle>Integration Broker Response</DefaultTitle><StatusCode>20</StatusCode><MessageID>55</MessageID><DefaultMessage><![CDATA[UserName not defined in database. (158,55)]]></DefaultMessage><MessageParameters><Parameter><![CDATA[ANONYMOUS]]></Parameter></MessageParameters></IBResponse></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>


The Integration Gateway setup, Service Configuration, and Service Operation setup looks fine, and the ANONYMOUS node Default User ID value matches a valid, existing PeopleSoft User ID.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms