E-PORTAL: "Could not open registry" Error with Single Link SSO from Portal to Content. (Doc ID 983986.1)

Last updated on JUNE 14, 2016

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.50 and later
Information in this document applies to any platform.
***Checked for relevance on 12-AUG-2013***


Symptoms

When Enterprise Portal uses a custom portal name and end user clicks on single link SSO to content, a new window opens and the following error occurs:

Could not open registry. Registry name:

In Enterprise Portal 9, create a CREF link (single link) to SSO into content.  By default Enterprise Portal uses the default Portal name EMPLOYEE.  Portal names are defined in "PeopleTools -> Portal -> Portal Definitions". 

Here's an example:
1.  In Portal, navigate to "PeopleTools -> Portal -> Structure and Contet".
2.  Click on "Add Content Reference"
3.  Update the following:

Name: MYTEST
Label: MYTEST
No Template = checked
Node Name: LOCAL_NODE
URL Type: PeopleSoft Generic URL
Portal URL: s/WEBLIB_EO_PE.PORTAL_HOMEPAGE.FieldFormula.IScript_Homepage_Nav?HP_NODENAME=HRMS&HP_TABNAME=DEFAULT

For "Content Reference Attributes", update the following:

Name: NAVNEWWIN
Attribute Value: true

The above assume that your nodes are setup correctly. 

Test case:

1.  Log into Enterprise Portal http://myportal.company.com/psp/myps/KPORTAL/KNODE/h/?tab=DEFAULT
2.  Click on MYTEST link
3.  New window appears with URL http://mycontent.company.com/psp/myhr/KPORTAL/HRMS/h/?tab=DEFAULT and the following error occurs:

Could not open registry. Registry name: KPORTAL

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms