Open UI : Toggle Applet Does Not Load (Doc ID 1906451.1)

Last updated on DECEMBER 07, 2016

Applies to:

Siebel Tools - Version 8.1.1.10 [23021] and later
Information in this document applies to any platform.

Symptoms

On : 8.1.1.10 [23021] version, Configuration - General

In Open UI, toggle applet is configured and after the PM and PR files are created the toggle applet does not load for the first time but after the refresh the applet works perfectly as excepted.

ACTUAL BEHAVIOR
---------------
Toggle applets are configured based on VBC.When PM/PR is not activated the applet load fine when toggling is done with Siebel provided lables.
 But when PM/PR is activated,which has a simple code to show text(what customer has to enter in textboxes) the toggle applet does not load the first time but when refresh is done,it loads properly from thereafter.

EXPECTED BEHAVIOR
-----------------------
Toggle Applet should load properly even 1st time as well with PM/PR is activated.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Login to Siebel Filed Service Application.
2. Navigate to view and click on Advance Search hyperlink.
3. Search For is a toggle and select a value from dropdown for toggle.
4.When PM/PR is activated,the applet loads only with textboxes and no other details but when refreshed it loads as expected.
5.When PM/PR inactivated,the applet loads perfect

BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users have to perform an extra refresh to load the toggle applet.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms