GetWarranties Method In FS Asset Warranty Service Not Working After Upgrade To 8.1.1.10 (Doc ID 1987474.1)

Last updated on MARCH 02, 2017

Applies to:

Siebel Field Service - Version 8.1.1.10 [23021] and later
Information in this document applies to any platform.

Symptoms

On Field Service

We have recently upgraded from Siebel 8.1.1.7 to Siebel 8.1.1.10. Recently we discovered that GetAssetWarranties Method is not working.
There is a 'Get Warranty' button in Site Map > Assets > drill down on an asset. If we click on the button, it does nothing because we didn't see any Warranty records under Assets.
When we simulate the business service method, it results in the Output Argument as StatusMsg even though the Warranty setup exists.


StatusMsg

"No warranties were found on current Product."


STEPS

The issue can be reproduced at will with the following steps:

1. Log into callcenter_enu.

2. Create 2 warranties for the product in Products > Warranties

Name: 1912-Base Warranty
Type: Manufacture
Subtype: Full Coverage
Duration (Days): 365
Parts: checked
Labor: checked

Name: 1912-Glass Cooktop
Type: Component
Subtype: Full Coverage
Duration (Days): 365
Parts: checked
Labor: checked

3.Connect to Client Side Administration - Business Service > simulator, and call FS Asset Warranty Service, Method GetAssetWarranties, and pass Asset Id as the method Input Argument.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms