Hyperlinks No Longer Working In Siebel OpenUI In Outgoing Emails Created From Communications Templates (Doc ID 2066637.1)

Last updated on MARCH 02, 2017

Applies to:

Siebel CRM - Version 8.1.1.14.3 [IP2014] and later
Information in this document applies to any platform.

Symptoms

On : 8.1.1.14.3 [IP2014] version, Comms Server & Email Response

Hyperlinks no longer working in Siebel OpenUI in outgoing emails created from Communications Templates.


Before the Siebel users started to use OpenUI, they have created HTML type Email Communications Templates containing hyperlinks, eg, for Twitter, and Facebook.

Before OpenUI, these hyperlinks were functional in the outbound emails (created via the Communication screen) when replying to inbound emails. However, after starting to use OpenUI, the hyperlinks are no longer functional on emails sent out via the templates. The bolded text, "Twitter" and "Facebook" still appears in the emails, but when hovering over them, the underlying URLs no longer appear.

We note that we can still create templates with hyperlinks using High Interactivity Mode  Web Client, and when creating outgoing emails using these templates in HI, the hyperlinks are fully functional on the resulting emails.

However, when using the same templates from OpenUI the observed behaviour is as follows:

1) In Site Map> Communications > Communications List > All Communications view, select a record from the list of inbound emails processed by Siebel Email Response.

2) Click on Reply button, to reply on the selected message

3) In the Outgoing Message applet, select values for Categories, and select a template which contains hyperlinks from the Body dropdown.

4) Edit the body of the message to personalize it for the recipient, then click on the Send button

5) The email arrives in the inbox of the recipient without functional hyperlinks

Also noticed that when accessing the template editor in OpenUI, hyperlink formatting (as well as most other html formatting) gets automatically removed from existing templates. We noticed this when querying for the template record in the database on the S_DMND_CRTN_PRG table, before and after accessing the template in the standard template editor.


Changes

Changing from High Interactivity mode to OpenUI mode for the Web Clients.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms