Siebel CTI with Cisco/AMC Failing in a Heterogeneous Setup (Doc ID 2106085.1)

Last updated on FEBRUARY 15, 2016

Applies to:

Siebel CRM - Version 15.7 [IP2015] and later
Information in this document applies to any platform.

Symptoms

On : 15.7 [IP2015] version, CTI

ACTUAL BEHAVIOR
---------------
Siebel CTI Setup Failing

Client is configuring CTI. The Connection to CISCO is via AMC middleware. They have done the basic configuration for CTI by enabling the Comm Mgmt group on our windows Server, Installing the AMC adapter software on Comm Server and setting up the agents in Siebel Application. The def file has also been imported and the corresponding driver parameters have been updated with relevant details of the Contact Canvas Server of AMC.
They have a heterogeneous setup wherein the Comm Server runs on dedicated Windows Machine whereas Object Manager runs on Linux Machine. Now after doing this configuration when the agent is logging into the application following error message appears on the Comm Toolbar:

“Failed on sending request or failed on processing request in server Communication Agent.(SBL-CSR-00306)”


Here are some more details from client env:

Siebel Application Version:15.7
AMC Siebel Adapter Version:
Comm Server OS: Windows 2012 R2
OM Server OS: OEL 6.6


 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms