Why Some Simulation Workflow Processes Are Shown As Active

(Doc ID 2110347.1)

Last updated on JUNE 30, 2017

Applies to:

Siebel Workflow - Version 8.1.1.14.5 [IP2014] and later
Information in this document applies to any platform.

Symptoms

Some Simulation Workflow Process are seen active in the application, under Administration - Business Process > Repository Workflow Processes > Active Workflow Processes, as seen in the below screen--shot:

 

Steps

1. Create an empty workflow process in Siebel Tools consisting of 2 steps,Start and End, and connect them with a connector.

2. Publish and Activate the workflow process.

3. Set it up Siebel Tools to simulate the workflow process using thick client, such as using sfs.cfg, and and IE8 browser.

4. Simulate the workflow process in Siebel Tools > Workflow Process, choose the workflow process named 'Empty Workflow Process', right click mouse and 
   choose 'Simulate', and click on Start. Continue to finish simulation, and you should get a message saying Simulation finishes successfully.

5. Log into application, go to Administration - Business Process > Repository Workflow Processes > Active Workflow Processes, query for workflow process name *Empty*,
    and you will see the 2 records :
   a)  Name = Empty Workflow Process, Version = 0, Repository Version = 0;
   b)  
Name = 'Simulation : 1-CGOT : Empty Workflow Process', Version = 1, Repository Version = 0.

6. Repeat steps 4 and 5.
In step 5,you see a new record is created. with a 
slightly different Name: Simulation : 1-FYGL : Empty Workflow Process, but the same Version = 1, Repository Version = 0.

 

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms