Open UI, Product Popup Applet Doesn't Work Correctly

(Doc ID 2143707.1)

Last updated on AUGUST 24, 2017

Applies to:

Siebel Field Service - Version 15.6 [IP2015] and later
Information in this document applies to any platform.

Symptoms

On : 15.6 [IP2015] version, Field Service

ACTUAL BEHAVIOR

Product Popup Applet doesn't work correctly

The Product Popup Applet doesn't work correctly when I click on the button "Add Items". No Fields are visible.( see attachment)
The behaviour exists with standard SRF.
With EnableScripting=FALSE, I have the same problem.
There are no PM/PR for this context.
The behaviour start since the application has been migred in IP15.6 with OpenUI. Before, in V7.2.16, the MVG works correctly.

Can you say why this problem, please ?



EXPECTED BEHAVIOR

The "Add Items" works correctly.



ERROR

ObjMgrMiscLog Error 1 00000002572c0e38:0 2016-05-06 08:34:41 (busobj.cpp (1689)) SBL-DAT-00222: An error has occurred creating business component 'Internal Product Multi Add' used by business object 'Order Entry'.

Please ask your systems administrator to check your application configuration.

ObjMgrLog Error 1 00000002572c0e38:0 2016-05-06 08:34:41 (sweframe.cpp (1382)) SBL-UIF-00300: Cannot create business component 'Internal Product Multi Add' for applet 'MultiAdd Product On Order'.


STEPS

The issue can be reproduced at will with the following steps:

1. Log into callcenter_enu, 15.8, as sadmin
2. Go to Site Map > Service Order > List, All Service Orders
3. Choose or create one service order, Type = Service Order, drill down on the Order #.
4. In Line Items, choose Line Details tab, choose Menu> Add Items.
5. The Pick Product pops up, and it is empty.



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms