Wrong Attributes are displayed in the Line Item Attribute Applet after Submit Order (Doc ID 2195054.1)

Last updated on MARCH 02, 2017

Applies to:

Siebel CRM - Version 8.1.1.14.15 [IP2014] and later
Information in this document applies to any platform.

Symptoms

On :  8.1.1.14.15 [IP2014] version, Order Management

ACTUAL BEHAVIOR  
---------------
Attributes XA appears to have dissappear after clicking 'Submit' to submit the order from the GUI.

This occurs in the Order Entry - Line Items XA View (Sales) view, which shows the attributes in the grandchild applet.

For instance, there are for line items, with attributes as below:

Line1:
Line2: attr2
Line3: attr3

In the above, Line1 has no attribute.

In this case, Line1 is highlighted in the Line items, and users click the 'Submit' button. Now when users highlight Line2 or Line3, no attribute is displayed in the Attribute applet. If Line3 was selected before clicking the Submit button, then it shows attr3 for all three line items. The log shows that the query is always querying the rowid of the last line item selected before clicking 'Submit'. If users navigate away then back, then the context is restored.

EXPECTED BEHAVIOR
-----------------------
Correct attributes should be displayed.

STEPS
-----------------------
1. Create 2 or more products with attributes.
2. Add the products to the line item.
3. Complete the order, and before clicking 'Submit', highlight one of the line items.
4. After submitting, observe that the attribute is displayed incorrectly.

BUSINESS IMPACT
-----------------------
This can cause confusions to the users.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms