Post Default Values Not Working On Order Entry - Line Items BC (Doc ID 2214973.1)

Last updated on MARCH 05, 2017

Applies to:

Siebel CRM - Version 15.10 [IP2015] and later
Information in this document applies to any platform.

Symptoms

On : 15.10 [IP2015] version, Configuration - General

ACTUAL BEHAVIOR
---------------
Post default values not working on Order Entry - Line Items BC

EXPECTED BEHAVIOR
-----------------------
post default values should work

STEPS
-----------------------
The issue can be reproduced at will with the following steps:


1.Create a product with which has NETWORK_ELEMENT_CD='Network Node'
Ex: RootProduct and you add ChildProduct1 and ChildProduct2 under relationship, make sure to have the default and min cardinality as 1
2.Create a New Catalog , while you create a catalog, make sure the Catalog Type is set to “Buying”
3.Add a Category, Add Products
4.Add Pricing for these.
5.Create a new Sales Order, Add the newly created Pricelist to it
6.Then from Browse catalog view, select the Catalog that you have created.
The Product Structure will be displayed in the Category Product list applet
5.Select the Root product and click on Add Item.
6.Now if you navigate to Line Items view you should be able to see the products added.
7.Then under Line Item Detail You can verify for Node fields.


BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, users see incorrect data when record is saved.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms