Unable To Set Values To CTI Parameter Variables In A CTI Command (Doc ID 2233803.1)

Last updated on FEBRUARY 14, 2017

Applies to:

Siebel CTI - Version 8.1.1.10 [23021] and later
Information in this document applies to any platform.
When an agent tries to do a blind transfer to number 1085, we are invoking a specific command BlindTransferPayByPhone. When this command is executed, we are trying to set parameter values using FINCORP Account business component fields which are active in the repository. We have tried 2 options, but neither of them is working.
Option 1 - Set the values in command data section. I have mentioned the CmdData parameters below. When we try this option, we do not get values of all the fields. Some fields which are active in repository are not fetched and following error is shown in OM log - Field "Test Balance" is not activated in BusComp "FINCORP Account". We have tried doing full compile many times, but we still get this error. The only difference we see in the fields where we can fetch the data is that they are set to force active in repository where as fields where we cannot fetch the data are not set to force active.


[CmdData:BlindTransferPayByPhone]
BusComp = "FINCORP Account"
Param.perVar2 = "{FINCORP Account.Test Balance}"
Param.perVar3 = "{FINCORP Account.Test Preferred Language}"
Param.perVar4 = "{FINCORP Account.Test Next Due Amount}"
Param.perVar6 = "{FINCORP Account.Test Booking State}"


Option 2 - Fetch the values from client side business service. We are invoking the BC field values using the PayByPhone method in Test_CTI3 Business service. We can retrieve all the values using the BS (even the fields which are not force active in repository) but the parameter values are not set when the command is executed.

[CmdData:BlindTransferPayByPhone]
ServiceMethod = "Test_CTI3.PayByPhone"
ServiceParam.FINAccountnum = "{Account Number}"

Attached are SCOMM and OM logs for each option along with BS and DEF File.

Please let us know how we can set the values to the parameters in the command.

Symptoms

 no values passed

Changes

 WorkTrackingObj in the Event Response  was used

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms