System Alert Notification Is Not Sending Email Alerts (Doc ID 2264299.1)

Last updated on MAY 12, 2017

Applies to:

Siebel CRM - Version 16.8 [IP2016] and later
Information in this document applies to any platform.

Symptoms

On : 16.8 [IP2016] version, System Admin

After configuring System Alert Notification to send mail the component ends with error. Though the component is in Error state users are not receiving any mails.

ERROR
-----------------------
GenericLog GenericError 1 0000001558f82314:0 2017-04-20 18:12:08 Message with subject "Notification message from enterprise [SJC_ENT], Siebel server [SJCSRVR], and component alias: [SiebSrvr]" could not be sent to CHANGE_ME since no sender specified and neither "Default From Address" or "Default Administrator Address" were specified for the SMTPSubsystem
GenericLog GenericError 1 0000001558f82314:0 2017-04-20 18:12:08 Error sending msg from "" to "CHANGE_ME" with subject "Notification message from enterprise [SJC_ENT], Siebel server [SJCSRVR], and component alias: [SiebSrvr]" using SMTP server "CHANGE_ME" on port 25.


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Create system alert profile
2. configure system alerts

3. set the following parameters

AdminEmailAddress
FromAddress
SMTPServerPort
SMTPServer
Message='This is a message from your Siebel Server: '
for named subsystem adminemailalert

4.For workflow proc manager

change param NotifyHandler=AdminEmailAlert,
NotifyOnTaskExit=1 for compdef wfprocmgr

5.Restarted services ..

To test , created new WF job , when it error out , ideally it should send email , which is not the case here.




BUSINESS IMPACT
-----------------------
Due to this issue, users cannot get email notification when component fails.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms